Operational Issues

Incident Report for Flock Safety

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:55 EDT

Monitoring

We have identified continued upstream issues with our hosting provider, impacting system wide availability. We are monitoring the situation and taking action to mitigate impact and restore services as soon as possible.

Footage is still being processed successfully and will be accessible when normal operations resume
Posted Oct 20, 2025 - 10:25 EDT
This incident affected: Search, Insights, and Administration, Alerts & Map, API & Webhooks, and VMS.