Search Ingest Delayed

Incident Report for Flock Safety

Resolved

This incident has been resolved.
Posted May 17, 2026 - 15:37 EDT

Monitoring

We have fixed the issue affecting real-time data. We are still working through historical data, so some older footage may take longer than usual to become searchable. Alerting and other real-time systems are unaffected.
Posted May 17, 2026 - 13:37 EDT

Update

We are continuing to work on a fix for this issue. Searches involving exact license plate matches and FreeForm search are unaffected. Alerting and other real-time systems are unaffected.
Posted May 17, 2026 - 11:38 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 17, 2026 - 09:28 EDT

Identified

Our search system is experiencing intermittent delays ingesting new footage. As a result, recent footage may take longer than usual to become searchable. Alerts and Hot List are unaffected.
Posted May 17, 2026 - 06:53 EDT
This incident affected: Search, Insights, and Administration and API & Webhooks.