Plate reads, insights, and alerts delayed

Incident Report for Flock Safety

Resolved

This issue has been resolved. All reads, insights, and alerts are realtime.
Posted Apr 03, 2026 - 11:08 EDT

Monitoring

The cause has been identified and plate reads are now being uploaded. Some cameras will be delayed as they process the backlog.
Posted Apr 03, 2026 - 10:44 EDT

Investigating

Plate reads are currently delayed, footage will be processed upon a fix being implemented.
Posted Apr 03, 2026 - 10:37 EDT
This incident affected: Search, Insights, and Administration and Alerts & Map.