Flock Aerodome DNS issue

Incident Report for Flock Safety

Resolved

The DNS issue affecting Flock Aerodome customers has been resolved. Operations are now back to normal.
Posted May 25, 2026 - 17:48 EDT

Investigating

We are currently investigating a DNS issue affecting Flock Aerodome customers in some regions. Our team is actively working to identify the root cause and restore normal service as quickly as possible.
Posted May 25, 2026 - 17:10 EDT
This incident affected: Aerodome.