Footage Ingestion Delayed

Incident Report for Flock Safety

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 14:45 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2025 - 14:16 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 09, 2025 - 13:54 EST

Investigating

We are currently investigating an issue where footage ingestion processing is delayed. New search results and alerts will be delayed.

Footage is still being captured and uploaded to the cloud successfully and will be accessible when normal operations resume.
Posted Dec 09, 2025 - 13:30 EST
This incident affected: Search, Insights, and Administration and Alerts & Map.