Service Interruption

Incident Report for Flock Safety

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 11:56 EDT

Monitoring

Verizon is experiencing an issue in which certain cellular devices have been deactivated. We have triaged the issue and are working on restoring service to those devices that have been impacted
Posted Mar 24, 2025 - 20:00 EDT
This incident affected: Alerts & Map.