Frontend Operational Issues

Incident Report for Flock Safety

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 14:29 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2025 - 14:22 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 11, 2025 - 14:15 EST

Investigating

We are currently investigating frontend operational issues within our system. Users on the west coast may have difficulty loading frontend web pages.

Footage is still being processed successfully and will be accessible when normal operations resume.
Posted Nov 11, 2025 - 14:08 EST
This incident affected: Search, Insights, and Administration and Alerts & Map.