Admin Site Degraded Performance
Incident Report for Flock Safety
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 17:01 EDT
Investigating
We are currently investigating this issue.
Posted Apr 18, 2024 - 16:52 EDT
This incident affected: Search, Insights, and Administration.